What should we call the new GraphObjAttributes?

EthanCerami, 9/30/2005 - This is a sample comment to get things started. Blah, blah, blah...

GaryBader - 9/30/2005 - I would like the name to contain the word 'attribute', since that's what we call this concept in Cytoscape - node and edge attributes. Data is too general a term.

EthanCerami 9/30/2005 - So, what's your proposed name? Attributes?

GaryBader - 9/30/2005 - How about CyAttributes? It is important for us to consistently name our core concepts across the board. Attributes is a core concept and we should always call it attributes. Other core concepts are at least Node, Edge and Network - these are all currently prefixed with 'Cy', so I think we should go with that prefix and stick with it for all core concepts made publicly available. Things that are prefixed with Cytoscape should be reserved for application specific classes, like the main class that users never need to access (currently, this is called CyMain, so that would have to be renamed and is a larger issue)

EthanCerami - 9/30/2005 - I like it. I second the vote for CyAttributes.

IlianaAvila - 9/30/2005 - I like CyAttributes too.

EthanCerami - 10/4/2005 - Subgroup (Ethan, Iliana and Nerius) all agree of name change. New interface will be called CyAttributes.

RFC_1/RFC1_Comment_Name (last edited 2009-02-12 01:03:37 by localhost)

Funding for Cytoscape is provided by a federal grant from the U.S. National Institute of General Medical Sciences (NIGMS) of the Na tional Institutes of Health (NIH) under award number GM070743-01. Corporate funding is provided through a contract from Unilever PLC.

MoinMoin Appliance - Powered by TurnKey Linux