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Cytoscape User Training:

Schedule of Training
1.
Introduction to Cytoscape Software

1.1
Cytoscape Layout and User Interface

1.2
Loading Networks

1.3
Cytoscape menus

1.4
Manipulating Networks
1.5  
Plug-ins and Plugin Manager

2.
Constructing and Loading Biological Networks into Cytoscape

2.1
Importing network files into Cytoscape

2.2
Importing text or Excel files

2.3
Creating an empty network and manually adding nodes and edges 
2.4 
Fetching data from external sources using other databases (Pathway Commons)
2.5
Saving Sessions

3.
Working with Attributes 

3.1
Importing Node Attributes

3.2
Viewing Attributes

3.3
Deleting Attributes

3.4
Editing Attributes

4
Working with Data

4.1
File format

4.2
Loading Expression Data

5
Customising Visualisation of Networks 

5.1 
The basics of VizMapper in Cytoscape

5.2 
Different types of Visual Mapping in Cytoscape

5.3 
VizMapper Examples

5.3.1
Example 1 – Creating a basic visual style and setting default values

5.3.2
Example 2 – Creating a New Visual Style with a Discrete Mapper

5.3.3
Example 3 - Visualizing Expression Data on a Network

5.3.4
Example 4 – Visualizing Expression Data on a Network (Continuous-Continuous Mapper)
5.4
Other aspects of visual styles

6
Filtering and Searching Networks 

6.1
Quick Find

6.2
Filters

6.3 
Network Statistics
Cytoscape:

Biological Network Analysis Training

1. Introduction to Cytoscape Software 
This section will introduce the Cytoscape user interface and includes central organising metaphors of Cytoscape: a network consists of genes/proteins/metabolites as nodes and interactions represented as links i.e. edges between nodes
First of all we will look at the basic UI of Cytoscape. Then we will load up a network to show all menu features of Cytoscape and some of the core functionality such as layout algorithms and also its plug-ins. 
1.1
Cytoscape Layout and User Interface
Launch Cytoscape: You should see a window that looks like this
[image: image1.emf]


· At the top of the Cytoscape Desktop window is the toolbar, which contains the command buttons. The name of each command button is shown when the mouse pointer hovers over it.

· In the upper right is the Main Network View window, where network data will be displayed. This region is initially blank.


· At left is the Control Panel (Network Management) Panel. This lists the available networks by name and provides information on the number of nodes and edges.

· Immediately below the Control Panel is the Network Overview Pane

· At lower right is the Data Panel which can be used to display node, edge, and network attribute data

The Network Management and Data browser panels are dockable tabbed panels known as CytoPanels. You can undock any of these panels by clicking on the Float Window control in the upper-right corner of the CytoPanel.

1.2
Loading Networks
We will now load a network to show all features of Cytoscape UI
· Go to File-> Import -> Network (multiple file types)
· You should see the Import Network File Dialog
· For Data Source Type select Local and then click Select
· Open the sampleData folder and select galFiltered.sif and then click on open and then Import
You should see the following:
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We will now use some of the basic Cytoscape functionality to re-organise and move around the network. 
· Go to the Layout -> yFiles -> Organic to change the layout of the network
· Use the Network Overview Pane to move and navigate across the network

· The Network Management Pane of the Control displays the number of nodes and edges in your network

· You can select nodes by clicking on them with the mouse, or by creating a selection area by dragging with the left mouse button

· Note that the Node Attribute Browser on the Data Panel lists the information stored on the nodes

· You can also select edges by clicking on a few edges; again, note that information about the edges can be viewed on the Edge Attribute Browser of the Data Panel

1.3 
Cytoscape menus

We will briefly run through all the menus available in Cytoscape.
File

The File menu contains basic file functionality:
· File → Open 

for opening a Cytoscape session file 
· File → New 
for creating a new network
· File → Save 

for saving a session file

· File → Import 
for importing data such as networks and attributes

· File → Export 
for exporting data and images. 

· File → Print 

allows printing
· File → Quit 

closes all windows of Cytoscape and exits the program
Edit

The Edit menu contains:

· Undo and Redo functions which undo and redo edits made in the Attribute Browser, the Network Editor and the Layout.

· Options for creating and destroying views (graphical representations of a network) and networks 
· Options for deleting selected nodes and edges from the current network.
· All deleted nodes and edges can be restored to the network via Edit → Undo. 
· Edit → Preferences → Properties to edit preferences for properties and plugins 

View

The View menu allows you to display or hide: 
· The network management panel (Control Panel)
· The attribute browser (Data Panel)

· Results Panel

· VizMapper
Select

The Select menu contains:

· Options for selecting nodes and edges

· The Select → Use Filters option allows filters to be created for automatic selection of portions of a network whose node or edge attributes meet a filtering criterion (see below for the filters section).
Layout

The Layout menu has an array of features for visually organising the network:
· Rotate, Scale, Align and Distribute are tools for manipulating the network visualisation. 
· The bottom section of the menu lists a variety of layout algorithms which automatically lay a network out.
Plugins

The Plugins menu contains options for managing your plugins (install/update/delete) and may have options added by plugins that have already been installed, such as the Agilent Literature Search or Merge Networks. 
· Depending on which plugins are loaded, the plugins that you see may be different than what appear here.
Help

· The Help menu allows you to launch the help viewer and browse the table of contents for this manual. 
· The “About…” option displays information about the running version of Cytoscape.

1.4 
Manipulating Networks

Zooming

Cytoscape provides two mechanisms for zooming:
i) Using the mouse – right click and move the mouse forward and backwards
ii) Using the zoom buttons on the toolbar to zoom in and out of the interaction network shown in the current network display. Zoom icons are detailed below:
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From Left to Right:

· Zoom Out; Zoom In; Zoom Selected Region; Zoom Out to Display all of Current Network

Panning the network

You can pan the network image by holding down the middle mouse button and moving the mouse in the main network window. You can also pan the image by holding down the left mouse button on the Network Overview panel in the lower left hand of the Cytoscape desktop

Manually rearrange a network

Select the nodes of interest and move them around. 
Automatically rearrange a network

There are a variety of layout algorithms which can be found in the Layout Menu

· Select Layout -> Cytoscape Layouts -> Degree Sorted Circle Layout -> All Nodes
· Your network has now been re-arranged and the algorithm partitions the network based on the connectivity of the nodes (i.e. degree) 
· The circles themselves are arranged in a radial tree layout fashion.

· This algorithm also calculates the degree for each node which cab be viewed in the Node Attribute Browser as follows:

· On the Data Panel, select the Node Attribute Browser tab, click on Select Attributes, select Degree then click on any node, the degree of the node as calculated by the Degree Sorted Circle Layout will be displayed

Try other layout algorithms from the Layout menu.

Rotating and Scaling your network

Finally you can rotate and scale your network within Cytoscape. 
· Go to the Layout Menu -> Rotate, the Tool Panel will appear at the bottom left of the screen
· Select a few nodes and click on Rotate Selected Nodes Only in the Tool Panel, move the slider to 90 degrees to rotate the nodes.
· Note you can also rotate the whole network. 
· You can also change the scale of the network (or selected nodes) by clicking on the Scale tab in the Tool Panel

1.5 Plug-ins and Plug-in Manager 

The Plugin Manager, first introduced in Cytoscape 2.5, allows users to quickly and conveniently add extra features to Cytoscape directly from within Cytoscape, eliminating the need for manual searches through different websites to install and update plugins.
If you do not have Internet access enabled, you will not see the list of available plugins or be able to automatically update existing ones; however, you will still be able to view and delete previously installed plugins.

Install new plug-ins

· Go to the Plugin Manager at Plugins -> Manage Plugins. On the left side of the window that pops up, you will see plugin folders labelled Currently Installed and Available for Install. Double-clicking on these will show sub-folders, and then the plugins themselves. To find out more about a specific plugin, click on its name to display some basic information on the right-hand side of the window.
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· Currently Installed folder contains a number of default plugins that are fully integrated in every copy of Cytoscape, as well as any additional installed plugins

· Available for Install folder displays plugins that may be installed. 
· To install jActiveModules: Go to the Available for Install folder, select the Analysis folder and then select jActiveModules v2.22. Click on the Install button at the bottom of the window
· Click on close to exit the Plug-in Manager

· Go to the Plugins menu and jActiveModules should appear in the list of plugins

To manually install a plugin 
· Go to the Cytoscape plugins page (http://cytoscape.org/plugins25/index.php), 
· Scroll down to find the plugin

· Click on the appropriate link to download the file, and then save it in the Cytoscape/plugins folder on your hard drive. 

· Cytoscape will require a restart in order to load the manually installed plugin. 

2. Constructing and Loading Biological Networks into Cytoscape 
In this section we will show the ways in which you can load in your own networks and associated data in to Cytoscape
There are three ways of creating networks in Cytoscape and we will deal with each of these in turn:
· Importing network files.

· Importing text or Excel files.

· Creating an empty network and manually adding nodes and edges.

First of all it’s useful to understand the files formats that are used for networks and the associated data.
2.1
Importing network files into Cytoscape
Cytoscape can read network/pathway files written in the following formats:

· Simple interaction file (SIF or .sif format)

· Graph Markup Language (GML or .gml format)

· XGMML (extensible graph markup and modelling language).

· SBML

· BioPAX

· PSI-MI Level 1 and 2.5

The simple interaction format (sif) is convenient for building a graph from a list of interactions. The main disadvantage is that this format does not include any layout information, forcing Cytoscape to re-compute a new layout of the network each time it is loaded.

An example of a sif file format is:
nodeA <relationship type> nodeB

nodeC <relationship type> nodeA
We will open galFiltered.sif in Excel to illustrate this
2.2
Importing text or Excel files
Cytoscape can also read file structures are the Delimited Text or Excel

· Go to File-> Import->Network from Table (Text/MS Excel)
· You should see the Import Network from Table Dialog Box
· In Data Sources, click on Select File 
· Select human_interactome_may07_small.tab.gz from the sampleData folder and then click on Open. You should now see the screen below.
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· In the Advanced section, select Show Text File Import Options

· In the Delimiter section, deselect Space 
· In the Attribute Names section, select Transfer first line attribute names

· In the Preview section click on the columns you want to import: Aliases A, Aliases B, Interaction Detection Methods, Interactor Types

The next step is to define the interaction parameters by specifying which columns of data contain the Source Interaction (i.e. source node), Target Interaction (i.e. target node) and Interaction Type in the Interaction Definition pane. If you set the Interaction Type as “Default Interaction”, all interactions will be given the value “pp”; this value can be modified in Advanced Options.
· For the Source Node
· For the Source Interaction dropdown list, select Column 1
· For the Target Node
· For the Target Interaction dropdown list Select Column 2 
· For the Interaction 

· For the Interaction Type dropdown list Select Column 4 
· Note Column 3 (“Interaction detection methods”) is highlighted in blue and will be imported as edge attributes.
· Click on Import
· In the Network Manager section of the Control Panel a network of 10,176 nodes and 61240 edges is highlighted in red. 
· Note that due to the size of the network, it will not be displayed in the Main window.
· To create the view, right click on the Network name and select Create View
2.3
Creating an empty network and manually adding nodes and edges
It is also possible to create new, empty networks that nodes and edges can be manually added to.
· To create an empty network, go to File → New → Network → Empty Network
· Select the Editor tab from the Control Panel
· To add a node to a network, drag and drop a node shape from the palette onto the canvas. Add another node 
· To connect two nodes with an edge, drag and drop an arrow shape onto a node on the canvas. This node becomes the source node of the edge.
· Move the cursor and a rubber-banded line will follow the cursor. As the cursor passes over another node, that node is highlighted and the rubber-banded line will snap to a connection point on that second node. 
· Click the mouse while over this node and the connection will be established.
· You can delete nodes and edges using the following method
· Select a node and hit the Delete button on your keyboard or by Edit->Delete selected nodes and edges

You can also create networks using the following scheme

· Double click on any empty space in the Main Network window and you should see the Input dialog box. Type in the following

· A binds B and then click on OK

· Repeat above and type in

· C binds D and then

· D binds A and then 

· A binds A
You should have a new network of 5 nodes and 4 edges (this information about the number of nodes can be found by clicking the Network tab on the Control Panel)

· You can edit the name of the network by right clicking on the Network name in the Control Panel and selecting Edit Network Title
2.4
Fetching data from external sources using other databases
Retrieving Pathways and Networks from Pathway Commons
· Select  File-> Import -> Network from web services 
· From the drop-down menu, select the Pathway Commons Web Service Client
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· Enter your search term; e.g. IL8 into the search box and then click on search
· Select the bio-molecule of interest; full details of the bio-molecule is shown in the bottom left panel
· To download a pathway, simple double click on the pathway of interest
· To download an interaction network click on the Interaction Networks tab and then click on Retrieve Interactions

· A new network will appear in the Main Network View

· Note that additional information about the network is also downloaded and can be viewed in the Data Panel. 
Linking to external data using LinkOut 
LinkOut provides a mechanism to link nodes and edges to external web resources within Cytoscape. 
· Select the galFiltered.sif network

· Select a node of interest
· Right click on a node and pop up menu with a list of web links will be displayed
· Select Model Organism Database and then SGD (yeast)
The external links are can be specified and edited by modifying the link out properties found under Edit → Preferences → Properties  
· Select the human_interactome_may07_small.tab network (make sure the network is displayed)
· Go to Edit → Preferences → Properties  
· Click on Add in the Properties section

· Type in nodelinkouturl.human.BioGrid as a Property Name
· Type in the following for Property Value, http://www.thebiogrid.org/search.php?keywords=%ID%&searchbutton=GO&organismid=9606
· Click on OK

· Type in SERPINA1 in the search box and click ok

· Right click in the selected node, select human and then BioGrid
2.5
Saving Sessions

You can save your Cytoscape sessions and export visualisations.

To save a session, go to File->Save
· Networks, Attributes, Visual Styles and Layouts will be saved as a CYS file

· You can export networks and attributes individually File->Export->Network as sif File… or File->Export->Node Attributes
You can also export images from Cytoscape:

· File->Export->Network View as Graphics

3
Working with Attributes 
Once you have created a network it is important to overlay relevant data and information. Cytoscape allows you to add information to the nodes, edges and the network as a whole.
3.1 Importing Node Attributes
There are various file formats for node and edge attributes and details can be found in the Help section in Cytoscape.

As of Cytoscape 2.4, importing delimited text and MS Excel attribute data tables is now supported.
The attribute file should contain a primary key column and at least one attribute column. 
We will look at the node attributes for the galFiltered network.
<Open galFiltered.nodeAttrTable.xls as an example>

To Import Node Attributes

· Select File → Import → Attribute from Table (Text/MS Excel) 

· Select one Node from the Attributes radio buttons. Cytoscape can import node, edge, and network attributes
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· To load a local file, click on the Select File button and open the sampleData folder, select galFiltered.nodeAttrTable.xls and click on Open
· (Optional) If the table is not properly delimited in the preview panel, change the delimiter in the Text File Import Options panel. The default delimiter is the tab. This step is not necessary for Excel Workbooks. 

· By default, the first column is designated as the primary key. Change the key column if necessary. 

· In the Advanced pane, select “Show Text File Import Options”
· In the Attribute Names pane, select “Transfer first line attribute names”
· In the Preview pane click on the columns you want to import (Click them all)
· Right click on the second column to change the from “alias” to “AlternativeName”
· Click on Import
3.2
Viewing Attributes

The node attributes can be viewed in the Node Attribute Browser of the Data Panel. To swap between nodes, edges or network browsers click on the appropriate tabs on the Data Panel

To view the node attributes you have just loaded in, click on the Select Attributes button in the Node Attribute Browser
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Select the following Node Attributes by clicking in check boxes 

· DB_Object_Name

· GO Biological Process

· GO Molecular Function

· GO Cellular Component

· Taxon

Select any nodes on the network and the attributes will be displayed in the Node Attribute Browser of the Data Panel:
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· The right-click menu on the Attribute Browser has several functions, such as exporting attribute information to spreadsheet applications.

· For example, use the right-click menu to Select All and then Copy the data, and then paste it into a spreadsheet application
· You can also link out to external resources by right clicking a cell in the table

3.3
Deleting Attributes
To delete attributes from the browser (and CYTOSCAPE!!) click on the Delete Attribute Button 
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Select the attributes you want to delete and then click on Delete
3.4
Editing Attributes

You can also edit attributes by double clicking on the appropriate cell in the Node Attribute Browser
3.5
Importing Ontologies
Note you can also import Ontology and Annotation by doing the following:
File-> Import-> Ontology and Annotation

4
Working with Data 
It is not only useful to add information to networks as we have just done. In addition to normal node and edge attribute data, Cytoscape also supports importing gene expression data (and any other molecular state data). 

Network-based analysis of High Throughput data is a very useful tool in systems biology and many other disciplines and this section will cover the integration of HTP data with biological networks in order to perform powerful visualisation and analyse in a biological context. 
PLEASE NOTE: DNA microarray data will be used as an example in this section of the tutorial however other types of data can be used
Gene expression data are imported using a different file format than normal attributes; however, the resulting attributes are not treated differently by Cytoscape. Gene expression data (like attribute data) can be loaded at any time, but are (generally) only relevant once a network has been loaded.

4.1
File format 
The file format for importing molecular state data (or any other data) consists of a header and a number of space- or tab-delimited fields, one line per node, with the following format: 

Identifier [CommonName] value1 value2 ... valueN [pval1 pval2 ... pvalN]

Let’s take a look at a Gene Expression file to get an idea of the format
· Brackets [ ] indicate fields that are optional.
· The first field is a primary key that identifies which Cytoscape node the data refers to. 
· In the simplest case, this is the gene name - exactly as it appears on the network generated by Cytoscape (NOTE it is case sensitive!).
· Alternatively, this can be some node attribute that identifies the node uniquely, such as a probeset identifier for commercial microarrays.

· The next field is an optional common name. It is not used by Cytoscape, and is provided strictly for the user's convenience.
· The next set of columns represent expression values, one per experiment. These can be either absolute expression values or fold-change ratios. Each experiment is identified by its experiment name, given in the first line. 
· Optionally, significance measures such as P values may be provided.
· If you are using significance measures, then your expression file should contain them in a second set of columns after the expression values. The column names for the expression significance measures need to match those of the expression values exactly. 

Expression data files commonly have the file extensions ".mrna" or ".pvals", and these file extensions are recognised by Cytoscape when browsing for data files. 

4.2
Loading Expression Data
We will now load the expression data for the galFiltered network: 

· Go to File → Import → Attribute/Expression Matrix.... 

· The Import an Attribute/Expression Matrix will be displayed

· In the field labelled "Please select an attribute or expression matrix file...", click on the Select button
· Select galExpData.pvals the sampleData folder and click on Open
· The identifiers used in this file are the same ones used in the network file sampleData/galFiltered.sif, so you do not need to touch the field labelled "Assign values to nodes using...” 
· Click on Import and details of the expression data will be displayed

That’s it! You’ve now integrated your experimental data with your network.

In the next section we will learn how to us the visualisation and filtering tools in Cytoscape to start to use this data for network-based analysis

5
Customising Visualisation of Networks 
Customising the way you visualise and manipulate networks is a key function of Cytoscape. This is achieved through the use of the VizMapper tool and in this section we will co through this functionality in some detail.
Following on from the previous sections, we will use the networks and data that have already been loaded in but remember, this will work with whatever data you are interested in.
5.1 
The basics of VizMapper in Cytoscape

To launch the VizMapper, either select the VizMapper tab on the Control Panel or click on the VizMapper icon at the top of the tool bar
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There are 3 components in the VizMapper UI:
Current Visual style


This panel allows you to create/delete/view/switch between different visual styles using the Current Visual Style options.

Defaults Appearance Style


Clicking on the section labelled "Defaults" on the Main Panel will bring up an editor, which allows users to visually edit the default appearance of nodes and edges for the selected visual style.

Visual Mapping Browser 

Visual Mapping Browser at the bottom displays the mapping details for a given visual style and is used to edit these details as well.
5.2 
Different types of Visual Mapping in Cytoscape
Before we start creating our own visual styles there are a few concepts that need to be understood.

The Cytoscape VizMapper uses three core concepts:

· A visual attribute is any visual setting that can be applied to your network. For example, you can change all nodes from circles to squares by changing the node shape visual attribute.

· A network attribute is any data attribute associated with a node or an edge. For example, each edge in a network may be associated with a label, such as “pd” (protein-DNA interactions), or “pp” (protein-protein interactions).

· A visual mapper maps network attributes to visual attributes. For example, a visual mapper can map all protein-DNA interactions to the colour blue, and all protein-protein interactions to the colour red

What can we visualise?
Cytoscape allows a wide variety of visual attributes to be controlled details of which can be found in the Cytoscape User Manual. Examples include:

Nodes

· Node Colour

· Node Opacity

· Node Border Colour

· Node Border Opacity

· Node Shape

Edges

· Edge Source and Target Arrow Colour

· Edge Source and Target Arrow Opacity

· Edge Label: the text label for each edge.

· Edge Label Colour

· Edge Label Opacity

· Edge Font: edge label font and size.

Global Visual Properties

· Background Colour

· Selected Node Colour

· Selected Edge Colour

The types of Visual Mappers

For each visual attribute, you can specify a default value or define a dynamic visual mapping. Cytoscape currently supports three different types of visual mappers:
1. Pass-through Mapper

The values of network attributes are passed directly through to visual attributes. A pass-through mapper is only used to specify node/edge labels. For example, a pass-through mapper can label all nodes with their common gene names.

2. Discrete Mapper

Discrete network attributes are mapped to discrete visual attributes. For example, a discrete mapper can map all protein-protein interactions to the colour blue.

3. Continuous Mapper

Continuous graph (usually numerical) attributes are mapped to visual attributes. 

5.3
VizMapper Examples

The best way to learn about the VizMapper is to try to use it on some real examples.

In this tutorial we will look at a few examples
· Example 1: Creating a Basic Visual Style and Setting Default Values

· Example 2: Creating a New Visual Style with a Discrete Mapper

· Example 3: Visualizing Expression Data on a Network

· Example 4: Visualizing Expression Data on a Network
5.3.1
Example 1 – Creating a basic visual style and setting default values

We will continue to use galFiltered.sif
· Ensure that galFiltered is selected in the Control Panel
· Open the VizMapper

· In the Current Visual Style section, create a new visual style by clicking the Options button  [image: image11.png]


 and selecting “Create new Visual Style”
· Enter a name for your new visual style when prompted, click on OK
· You will see an empty visual style in the VizMapper Main Panel, as shown below.
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Since no mapping is set up yet, all visual attributes are listed in the Unused Properties category of the Visual Mapping Browser. 
To edit default values, open the Default Appearance Editor by clicking on the Defaults graphics window (shown below) in the VizMapper Main Panel.
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· The next step is to change the default node shape. 

· To set the default node shape to triangles, click Node Shape in the Default Visual Properties list. A list of available node shapes will be shown. 

· Click on the Triangle icon and then click the Apply button. 

· The Default Appearance Editor will be automatically updated. 

· The next step is to change the node colour

· Click on Node_Fill_Color in the Default Visual Properties list, the colour selection panel will appear. Select red, then OK and then Apply
· The end result is that all nodes are red triangles

· Other default values can be edited by clicking on visual attribute names on the list. 

· To change default edge properties, select the Edge tab on the Default Visual Properties section
· To change default global properties, select the Global tab on the Default Visual Properties section
[image: image14.png]



5.3.2
Example 2: Creating a New Visual Style with a Discrete Mapper 
The following tutorial demonstrates how to create a new visual style using a discrete mapper. Recall that discrete network attributes are mapped to discrete visual attributes. The goal is to draw protein-DNA interactions as dashed blue lines, and protein-protein interactions as solid red lines.

Using galFiltered.sif
· Open the VizMapper

· In the Current Visual Style section, create a new visual style by clicking the Options button  [image: image15.png]



· Select Create new visual style

· Then enter a name for your new visual style when prompted, click on OK
· Next step is to choose a visual attribute 

· Since we want to change the edge colour, double click the Edge Colour entry listed in Visual Mapping Browser. Edge Colour will now appear at the top of the list, under the Edge Visual Mapping category 

· The next step is to choose a network attribute
· Click on the cell to the right of the Edge Colour entry and select interaction from the dropdown list that appears

· The next step is to specify the type of mapping

· Click on the cell next to the Mapping Type entry and select Discrete Mapper from the dropdown list

· All available attribute values for interaction will be displayed

· The next step is to set the mapping relationship

· Click the empty cell next to pd (protein-DNA interactions).

· On the right side of the cell, ... and X buttons will appear

· Click on the ... button. A popup window will appear; select blue and the change will immediately appear on the network window.

· Repeat above steps for pp (protein-protein interactions) but select red as the edge colour

Can you also specify that your protein-protein interactions should be solid and the protein DNA interactions will be dashed?
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5.3.3
Example 3: Visualizing Expression Data on a Network (Using continuous mapper)
The following tutorial demonstrates how to create a new visual style using a continuous mapper.
The goal is to superimpose gene expression data onto a network and display gene expression values along a colour gradient.

Using galFiltered.sif
· (Load in galFiltered.sif and the associated expression data set: galFiltered.pvals)

· (Ensure galFiltered is selected in the Control Panel)

· Open the VizMapper
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In the Current Visual Style section, create a new visual style by clicking the Options button 

· Select Create new visual style
· Then enter a name for your new visual style when prompted, click on OK
· Next step is to choose a visual attribute 

· First change the label names to something more meaningful

· Since we want to change the node label, double click the Node Label entry listed in Visual Mapping Browser. Label will now appear at the top of the list, under the Node Visual Mapping category 

· The next step is to choose a network attribute
· Click on the cell to the right of the Node Label  entry and select GeneNames from the dropdown list that appears

· The next step is to specify the type of mapping

· Click on the cell next to the Mapping Type entry and select Pass-through Mapping from the dropdown list
· The next step is to change the node colour based on expression value

· Since we want to change the node colour, double click the Node Colour entry listed in Visual Mapping Browser. Node Colour will now appear at the top of the list, under the Node Visual Mapping category 

· The next step is to choose a network attribute
· Click on the cell to the right of the Node Colour entry and select gal80Rexp from the dropdown list that appears

· The next step is to specify the type of mapping

· Click on the cell next to the Mapping Type entry and select Continuous Mapper from the dropdown list

· The next step is to define the points where the colours will change

· Click on Graphical View in the Node Visual Mapping category. The Gradient Editor for Node Colour will appear

· Click the Add button thrice to create three data points, which will show up as overlapping triangles at the right of the scale. 

· Click and drag one point to -1, or type the value in the Range Setting box. Set the second point to 0 and the third to 1
· The next step is to define the colours between points. 

· Double-click on the leftmost triangle (facing left) and a colour palette will appear. Choose a shade of green and click OK. 

· Make the triangle at -1 a shade of green.

· Double-click on the triangle set at 1, and set its colour to red. 

· Set the rightmost triangle to Red.

· The end result is shown below
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The colour gradients will immediately appear in the network window. All nodes with a gal80RGexp value less than –1 will be set to green, and all nodes with a gal80RGExp value greater than 1 will be red. 
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o Double-click on the triangle set at 1, and set its colour to red.

o Set the rightmost triangle to Red.

o The end result is shown below
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5.3.4
Example 4: Visualizing Expression Data on a Network (Using continuous mapper)
The goal is to superimpose gene expression data and p values onto a network and display gene expression values along a colour gradient, p values according to size

Using the visual style created in exercise 5.3.4
· Since we want to change the node size, double click the Node Size entry listed in Visual Mapping Browser. Label will now appear at the top of the list, under the Node Visual Mapping category 

· The next step is to choose a network attribute
· Click on the cell to the right of the Node Size entry and select gal80Rsig from the dropdown list that appears

· The next step is to specify the type of mapping

· Click on the cell next to the Mapping Type entry and select Continuous Mapping from the dropdown list
· Click on the cell next to the Mapping Type entry and select Continuous Mapper from the dropdown list

· The next step is to define the points where the colours will change

· Click on Graphical View in the Node Visual Mapping category. The Continuous Mapping Editor for Node Size will appear
· The y-axis represents the node size and the x-axis shows the range of the attribute to be mapped. 
· The first step is to set the range for our node size (which will be 20-60). Double click on the right-most solid red square on the y- axis and enter 60. Then double click on the left-most solid red square and enter 20 

· The next step is to set the range for the p values (minimum value-0.05). Click on the Add button twice to create two data points which will appear as inverted triangles at the right of the screen. Slide one triangle all the way to the left. Slide the other triangle to 0.05 (or enter 0.05 in the Range Setting box)
· The next step is link the size of the nodes to p values

· Double click on the open red square for the triangle set at the lowest p value and enter 60

· Double click on the open red square for the triangle set at p=0.05 and enter 20 (all nodes with a p value >0.05 will have a node size of 20)

· The end result will look like this
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6
Filtering and Searching Networks
Searching and filtering networks is another powerful feature of Cytoscape. In this section we will cover how to go about navigating your networks
6.1
Quick Find

Cytoscape includes a Quick Find feature, which enables you to quickly find nodes and edges.
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Using Quick Find is very simple. 

Using galFiltered.sif
· (Load in galFiltered.sif)
· (Ensure galFiltered is selected in the Control Panel)

· Type YPL248C in the search box which will automatically display a list of all matching nodes

· Hit the returned key and the matching node within the network will be highlighted and zoomed in
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Configuring Quick Find

Quick Find works by creating an internal index of all nodes within the network. By default, Cytoscape indexes all nodes by the node identifier. However, you can configure Quick Find to index nodes or edges, and you can set any attribute as the index.

· For example, to index the network based on cellular location, click the Quick Find configuration button [image: image19.png]



· In the Select Index Type, select Index Nodes
· Select GO_Cellular_Component from the dropdown list of the Search on Attribute section and then click on Index Network
· Type Cytoplasm in the search box

· The resulting nodes are highlighted in the network

Dynamic Filtering via Quick Find

If you choose to index on a numerical attribute, the Quick Find search box changes to a dynamic slider for quick filtering.

· To index the network based on expression, click the Quick Find configuration button [image: image20.png]



· In the Select Index Type, select Index Nodes
· Select gal80RGexp from the dropdown list of the Search on Attribute section and then click on Index Network
· A range slider will appear in the search box

· Move the slider and the resulting nodes are highlighted in the network

6.2
Filters
Filters allow you to quickly select multiple nodes or edges of interest by comparing node and edge attributes loaded onto Cytoscape networks to properties you specify. 

For example, you can select all the nodes whose name contains a specific pattern, or whose numeric attribute value falls within a certain range. Cytoscape provides filters as a core plugin. 

Users can perform complex selection by defining basic filters (selection based on a single attribute) and compound or Boolean filters (combining basic filters for selection based on multiple attributes).

There are two types of filters

- Newly designed which allows users to filter on attributes

- Old filters which allows users to filter on attributes and topology

Filtering on Attributes

Using New Filters

· [image: image30.png]Google



Click on the filter icon on the tool bar 

· Alternatively click on the Filters tab on the Control Panel
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· The next step is to define a filter (numerical)

· Click on the Filter Option button, select Create New Filter and enter a name for your filter

· Select gal80RGexp from the Attribute dropdown list of the Filter Definition section

· Click on Add and a slider should appear

· Set the slider to -2 to 0 and then click on Apply
· The resulting nodes will be highlighted in the network

· (You can work with the resulting nodes on a separate network, go to File-> New-> Network-> From selected nodes, all edges)

You can also combine filters 

· Select GO_Cellular_Component from the Attribute dropdown list of the Filter Definition section

· Type in cytoplasm in the search box 

· Click on the + sign in the Advanced section and select AND in the Relation section 

· Click on apply

· (You can work with the resulting nodes on a separate network, go to File-> New-> Network-> From selected nodes, all edges)

Filtering on Topology
· Click on the Filter Option button, select Create New Topology Filter and enter a name for your filter

· Select nodes with at least 1 neighbour within distance 2

· And select the filter you created in the previous exercise from the dropdown menu
· Click on Apply
· The resulting nodes will be highlighted in the network

· (You can work with the resulting nodes on a separate network, go to File-> New-> Network-> From selected nodes, all edges)

6.3 Finding ‘Active’ Sub-networks (jActiveModules)
This uses the jActiveModules plug-in (Ideker et al Bioinformatics 18 (Suppl. 1): S233-S240, 2002) and is used to identify ‘active’ sub-networks containing genes (nodes) that are not only significantly expressed (over particular conditions) but that are also highly connected. In this way, areas of the network affected by a particular experimental condition can be identified. 
Using galFiltered.sif
· (Load in galFiltered.sif)

· (Ensure galFiltered.sif is selected in the Control Panel)
· Launch NetworkAnalyzer (Plugins-> jActiveModules) and the jActiveModules Plugin tab will appear in the Control Panel
· Under Expression Attributes for Analysis select gal1RGsig, gal4RGsig,  and gal80RGsig

· Run the search algorithm by clicking on Find Modules
· The results will  be displayed in the Results Panel
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· ‘Active’ subnetworks for a particular condition are highlighted in red
· Select a network of interest and create a new sub-network. The resulting nodes will be highlighted in the network

· You can work with the resulting nodes on a separate network, go to File-> New-> Network-> From selected nodes, all edges
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