
The Cytoscape Test Plan 
 
The purpose of this document is to describe testing procedures to 
ensure that new releases of Cytoscape do not break existing 
functionality. The release is broken down into two general sections: 
Coverage Testing and Workflow Testing. 
 

Coverage Testing 
 
This section describes tests for Cytoscape that must be run by 
hand. 
 

File Menu 
 
Open Session File 
 
Procedure 
 
1. Start Cytoscape. 
2. Click the "Open Session File" icon on the Toolbar. 
3. Open a session file. 
4. Download and save corrupted_networkname.cys 
5. Open that file by clicking File>Open>new Session file  
 
Expected Results 
 
1. The "Open a Session File" dialog should appear. 
2. The network contained in the session file should be visible in 
Cytoscape. 
3. Opening the new session file should give a warning message: "Current 
session will be lost. Do you want to continue?" 
4. The attached session file is corrupted: it should lead to an error box: 
"Cannot open the session file: Session file corrupt: Filename 
Saccharomyces cerevisiae.xgmml does not correspond to a network of 
that name in session file"  
 
Save Current Session As 
 
Procedure 
 
1. Start Cytoscape. 
2. Click the "Save Current Session As" icon on the Toolbar.  

 
Expected Results 



 
1. A "Saving Cytoscape Session" status window should appear.  
 
Import Menu 
 
Network 
 
Multiple File Types 
 
From Table 
 
Procedure 
 
1. File-->Import-->Network from Table 
2. Press Select File(s) button and select text or Excel table network file 
3. Select Source, Target, and Interaction Type 
4. Click other columns header to enable edge attribute import. 
5. Check Show Text File Import Options and check Transfer first line 
6. Press Import  
 
Expected Results 
 
1. Network Table Import GUI will be displayed 
2. Preview of the table file will be displayed on Preview panel. Default 
delimiters are space and tab. 
3. Selected columns will be shown in purple, orange and red. 
4. Enabled edge attribute columns are shown in blue. 
5. Column header is set to the first line of the table. Column selections 
should not be lost. 
6. A new network will be created. Network name should be the file name 
of the table.  
 
From Web Service 
 
Attributes 
 
Export 

 
Zoom out / Zoom in 
 
Procedure 
 
1. Start Cytoscape. 
2. Load a network. 
3. Click the "Zoom Out" icon on the Toolbar. 



4. Click the "Zoom In" icon on the Toolbar.  
 
Expected Results 
 
1. Clicking "Zoom Out" should result in the view of the network being 
more zoomed out and less detailed. 
2. Clicking "Zoom In" should result in the view of the network being more 
zoomed in and more detailed.  
 
Zoom to display all of current network 
 
Procedure 
 
1. Start Cytoscape. 
2. Load a network. 
3. Click the "Zoom to display all of current network" icon on the Toolbar.  
 
Expected Results 
 
1. The view of the network should zoom in or out to fit the entire network 
in the main window at the highest possible zoom factor.  
 

Help 
 
Procedure 
 
1. Start Cytoscape. 
2. Click the "Help" icon on the Toolbar.  
 
Expected Results 
 
1. The Cytoscape Users Manual should open.  
 

Open VizMapper 
 
Procedure 
 
1. Start Cytoscape. 
2. Click the "Open VizMapper" icon on the Toolbar.  
 
Expected Results 
 
1. The VizMapper interface should open in Control Panel.  
 

Use Filters 



 
1. Start Cytoscape 
2. Import a test small network (with less than 1000 nodes/edges) and 
attributes 
3. Click the icon Use filters on toolbar, or click Filters tab on the control 
panel. This will select the filer UI. 
 
Define a filter with UI widgets 
 
Procedure  
 
1. Click Option icon and select create new filter, enter a filter name 
2. Click the plus sign (advanced) to choose what will be selected -- nodes 
or edges or both 
3. Define the filter by adding UI widgets to filter definition panel -- 
selecting attributes from the attribute/Filter comboBox and click add 
button 
4. Widgets may be removed by click on the trash-can icon at its right 
5. Click the radio button (relation) to determine the relationship between 
the widgets 
6. Define the details of the filter by click on appropriate checkbox, not or 
negation in advanced panel, select appropriate value for each 
textIndexedComboBox, and move the bar on RangeSlider.  
 
Expected results 
 
1. A new filter with given name should appear in the current filter 
selection comboBox 
2. TextedIndexed combobox should be added to the filter definition 
panel if the selected attribute is type string or simple string list, The UI 
widget is RangeSliderBar if the attribute is numeric type. 
3. When a new widget is added or deleted, or a checkbox/radio button is 
clicked, the selection on the network view will be made in real time. 
4. If there are more than one filter defined, selection of different filter in 
the current filter comboBox will apply the filter immediately.  
 
Define a complex filter 
 
After a filter is defined, it will appear in the attribute/filter comboBox 
when defining other filter, and can then be used by the definition of other 
filter. Such filters are called complex filter, their behavior should be the 
same as simple filter defined above and applied in real time. 
 
Topology filter 
 



Topology filter can select nodes based on its topology (number of 
neighbors) and properties of their neighbor. Nodes with certain 
properties can be selected by other filter. 
 
1. Define a filter to select nodes with certain properties 
2. Create a topology filter based on the defined filter  
 
Expected result 
 
The topology filter will be applied in real-time after user make changes to 
the filter definition 
 
Interaction filter 
 
Interaction filter will select nodes/edges based on the properties of 
edges/nodes it connected. Because interaction filter depends on other 
filter, the menu item Create new (Node/Edge)interaction filter will be 
disabled if there is no other filter existing. 
 
1. Create a simple filter to select edges only 
2. Create a new nodeInteractionFiler 
3. Define the nodeInteractionFiler based on the simple filter  
 
Expected result 
 
The interaction filter will be applied automatically. 
 
Read/write filter properties 
 
In the advanced panel, there is an option Scope, by default the checkbox 
session is checked. This option will determine where the filter is saved. 
 
1. Define a filter 
2. Check the checkbox global 
3. Exit Cytoscape 
4. Restart cytoscape  
 
Expected result 
 
The previous defined filter will appear in the filter comboBox after 
cytoscape is initialized. 
 
Switch network 
 
1. Import another network to Cytoscape 



2. Select the network view just created, then select the other network 
view.  
 
Expected result 
 
The current selected filter will be applied to the current network if the 
focused view is changed 
 
Large network (more than 1000 nodes/edges) 
 
If a network is large enough, with more than 1000 nodes/edge, the filter 
selected won’t be applied to the network automatically. To apply the 
filter, click the apply button. 
 
By default, the cutoff value for the dynamic filter is 1000 nodes/edges. 
This value can be changed by defining a property dynamicFilterThreshold 
in preferences panel of Cytoscape (Edit-->Preferences-->Properties). 
 

Search 
 
Procedure 
 
1. Start Cytoscape. 
2. Load a network. 
3. Type a search term in the "Search" field in the Toolbar. For example, 
search for the ID of one of the nodes in the network.  
 
Expected Results 
 
1. If you searched for a node that is in the currently loaded network, the 
node will become highlighted.  
 

File Menu  
 
File -> New -> Session 
 
Procedure 
 
1. Start Cytoscape. 
2. Click File -> New -> Session 
3. Load a network. 
4. Click File -> New -> Session 
5. Click yes. 
6. Repeat, Click no.  
 



Expected Results 
 
1. Nothing should happen because no networks have been loaded, there 
is no session yet. 
2. You should be prompted with a dialog that reminds you that your 
current session will be lost. 
3. If you click yes, you should get a new session with no networks in the 
network manager. 
4. When you click no, you should see your existing session without any 
changes.  
 
File -> New -> Network -> Empty Network 
 
Procedure 
 
1. Start Cytoscape. 
2. Click File -> New -> Network -> Empty Network  
 
Expected Results 
 
1. An empty network and view should be created. The Control Panel 
should be changed to the Editor Tab.  
 
File -> New -> Network -> Construct network using cPath... 
 
Procedure 
 
1. Start Cytoscape. 
2. Click File -> New -> Network -> Construct network using cPath... 
3. Type the example "p53" into the cPath dialog. 
4. Change the species drop-down menu to "Homo Sapiens" 
5. Click Help then close the Help dialog. 
6. Click About the close the About dialog. 
7. Click Search. 
8. Click the "X" in the dialog frame to close the cPath dialog.  
 
Expected Results 
 
1. The cPath dialog should appear. 
2. Another dialog should be displayed with text describing the features of 
the cPath dialog. 
3. Another dialog should be displayed with text describing the authors of 
the software. 
4. A network should be loaded with more than one node. 
5. The dialog should close.  



 
File -> New -> Network -> Clone current network 
 
Procedure 
 
1. Start Cytoscape. 
2. Load a network. 
3. Lay the network out in something other than a grid. 
4. Change the visual style to something other than default. 
5. Click File -> New -> Network -> Clone current network.  
 
Expected Results 
 
1. You should see a new network with the same name as the previous 
network, but with the word " Copy" appended to it. This view should have 
the exact same node layout and visual style as the original network.  
 
File -> New -> Network -> From selected nodes, all edges 
 
Procedure 
 
1. Start Cytoscape. 
2. Load Network. 
3. Make sure that NO nodes or edges are selected (i.e. click on the view 
somewhere other than on a node or edge). 
4. Click File -> New -> Network -> From selected nodes, all edges. 
5. Select some nodes and edges in the view. 
6. Click File -> New -> Network -> From selected nodes, all edges.  
 
Expected Results 
 
1. You shouldn't be able to click this option because it should be grayed 
out. This is because no nodes or edges are currently selected. 
2. A new network and view should be created. The nodes should have the 
same layout and visual styles as the parent network.  
 
File -> New -> Network -> From selected nodes, selected edges 
 
Procedure 
 
1. Start Cytoscape. 
2. Load Network. 
3. Make sure that NO nodes or edges are selected (i.e. click on the view 
somewhere other than on a node or edge). 
4. Click File -> New -> Network -> From selected nodes, selected edges. 



5. Click Select -> Mouse Drag Selects -> Nodes Only. 
6. Select some nodes in the view. 
7. Click File -> New -> Network -> From selected nodes, selected edges.  
 
Expected Results 
 
1. You shouldn't be able to click this option because it should be grayed 
out. This is because no nodes or edges are currently selected. 
2. A new network and view should be created. This network should only 
include the selected nodes and no edges. This network will be laid out as 
in the original network including the visual style.  
 

Edit Menu 
 

View Menu 
 
View Control/Results Panel 
 
Procedure 
 
1. Start Cytoscape. 
2. Click View -> Hide control panel 
3. Click View -> Show results panel 
4. Click View -> Show control panel 
5. Click View -> Hide results panel  
 
Expected Results 
 
1. The control panel; the left panel on the screen, should disappear. The 
network in the networkpanel adapts by centering in the panel 
2. The results panel; empty grey panel should appear to the right (fills 
half the screen? is not intended behavior; Piet) 
3. The control panel reappears with original size 
4. The original situation is restored  
 
View Data Panel (Attribute Browser) 
 

Procedure 
 
1. Start Cytoscape and load session file with several attributes 
2. Click Select Attributes icon and select attributes from the popup list 
3. Select several nodes 
4. In the data panel select a cells by clicking (w/shift or ctl for multiple 
selection) 
5. Swap columns and select nodes again 



6. Click on Create new attribute icon and select String Attribute. Then 
type name of the new attribute 
7. Click Attribute Batch Editor icon on the right. Then select Set and the 
new attribute name created in the last step. Type any word and click Go 
8. Click Delete attributes... icon and select one or more attributes. Then 
press Delete 
9. Click View -> Hide data panel 
10. Click View -> Show data panel  
 
Expected Results 
 
1. After selecting attributes from list, they will be shown as column 
names 
2. After selecting nodes they turn yellow 
3. After selecting cells in the attribute browser, the corresponding node 
colors green 
4. After swapping and selecting nodes again, the column order should 
remain the same 
5. New attributes should be shown on the table (in the last column) 
6. New values should be assigned to the selected attribute name column 
7. After deletion, attributes should be removed from table AND attribute 
list 
8. After clicking ->Hide data panel, the lower panel disappears and the 
graph zooms out to fill the complete larger network panel 
9. After clicking ->Show data panel, the datapanel reappears, including 
data corresponding to the selected nodes; the graph fills the smaller 
networkpanel  
 

Select Menu 
 
Mouse drag selects 
 
Procedure 
 
1. Start Cytoscape. 
2. Load a network. 
3. Click Select->Mouse drag selects 
4. Left click mouse on network screen, while keeping pressed draw 
rectangle around a set of nodes and edges 
5. Press CTRL+SHIFT+E and repeat selection 
6. Click Select->Mouse drag selects->Nodes Only  
 
Expected Results 
 



1. After clicking Select->Mouse drag selects, verify that Nodes and Edges 
is ticked 
2. After drawing select rectangle nodes and edges are selected 
3. After pressing CTRL+SHIFT+E selected nodes and edges are deselected 
and in subsequent selection with mouse, only edges are selected 
4. After Select->Mouse drag selects->Nodes Only, selected edges are 
deselected and in subsequent selection with mouse, only nodes are 
selected  
 

Nodes 
 
Procedure 
 
1. Start Cytoscape. 
2. Load a network. 
3. Select a subset of nodes and edges by mouse dragging 
4. Click Select->Nodes->Invert node selection 
5. Press CTRL+H 
6. Click Select->Nodes->Show all nodes 
7. Click Select->Mouse drag selects->Edges Only 
8. Select a subset of edges only by mouse dragging 
9. Press CTRL+A 
10. Click Select->Nodes->Deselect all nodes 
11. Click Select->Nodes->Nodes connected by selected edges 
12. Press CTRL+6 
13. Load galFiltered.gml from testData directory 
14. Click Select->Nodes->By name... 
15. In the textbox type: yh* 
16. Copy and paste the following text in a texteditor and save somewhere 
as file  
 
YHR115C 
 
YHR174W 
 
YHR141C 
 
1. Click Select->Nodes->From file... 
2. In the dialog box select the file saved above  
 
Expected Results 
 
1. After selection a subset of nodes and edges is selected 
2. After Select->Nodes->Invert node selection, all other nodes are 
selected, current selection deselected, edges stay selected 



3. After CTRL+H selected nodes and their connecting edges disappear 
4. After Select->Nodes->Show all nodes, all nodes and edges reappear 
5. After Selecting edges only and pressing CTRL+A all nodes are selected; 
the selected edges stay selected 
6. After clicking Select->Nodes->Deselect all nodes are deselected; the 
selected edges stay selected 
7. After clicking Select->Nodes->Nodes connected by selected edges, 
the nodes connected by selected edges are selected 
8. After pressing CTRL+6, the node selection is expanded with the first 
neighbours; their connecting edges are not selected 
9. After loading the galFiltered.gml and selecting nodes by name yh* 
verify that 13 nodes starting with YH are selected 
10. After loading the file verify that YHR115C, YHR174W and YHR141C 
are selected  
 

Edges 
 
Procedure 
 
1. Start Cytoscape. 
2. Load a network. 
3. Select a subset of nodes and edges by mouse dragging 
4. Click Select->Edges->Invert edge selection 
5. Press ALT+H 
6. Drag the group of selected nodes for some distance over the screen 
7. Click Select->Edges->Show all edges 
8. Click Select->Mouse drag selects->Nodes Only 
9. Select a subset of node only by mouse dragging 
10. Press ALT+A 
11. Click Select->Edges->Deselect all edges 
12. Press ALT+E 
13. Click Select->Mouse drag selects->Nodes and Edges 
14. Click Layout->yfiles->Hierarchic 
15. Select a subset of edges including some angled edges 
16. Click Select->Edges->Smooth selected edges 
17. Click Select->Edges->Straighten selected edges  
 
Expected Results 
 
1. After selection a subset of nodes and edges is selected 
2. After Select->Edges->Invert edge selection, all other edges are 
selected, current selection deselected, nodes stay selected 
3. After ALT+H selected edges disappear, the nodes stay visible 
4. After Select->Nodes->Show all nodes, all edges reappear correctly 
drawn wrt the new position of the nodes 



5. After selecting a subset of nodes and pressing ALT+A, all edges are 
selected, subset of nodes stays selected 
6. Click Select->Edges->Deselect only deselects edges 
7. Pressing ALT+E selects all edges connecting to the node selection 
8. After applying the hierarchic layout to (eg galFiltered.gml) the network 
edges with angles are present 
9. Selecting these angled edges and applying Smooth selected edges, 
results in a curved edge; straightening these returns them to their angled 
state  
 

Layout Menu 
 
Plugins Menu 
 
Plugins -> Manage Plugins -> Install 
 
Procedure 
 
1. Start Cytoscape 
2. Click Plugins -> Manage Plugins. 
3. In the Manage Plugins window, expand the "Currently Installed" folder 
by double-clicking the folder icon, then expand the Core folder by 
clicking on the arrow symbol next to it. 
4. Select any of the plugins listed by clicking on it. 
5. Expand the "Available for Install" folder. 
6. Select any plugin that is not already installed. Click the Install button.  
 
Expected Results 
 
1. The Manage Plugins window should open with folder "Currently 
Installed" and "Available for Install" in the left panel. The first time 
Manage Plugins is selected in an instance of Cytoscape, a connection 
status window should open before the Manage Plugins window appears. 
2. Under "Currently Installed" and "Available for Install" there should be 
subfolders listing individual plugins. 
3. When clicking on a plugin, information about the plugin should appear 
in the right panel. 
4. During plugin installation, you should get an installation progress 
window. When installation is complete, a message in red is displayed 
under the left panel stating that the installation is complete. 
5. The newly installed plugin should be visible under "Currently Installed" 
folder.  
 
Plugins -> Manage Plugins -> Change Download Site 
 



Procedure 
 
1. In the Plugin Manager window, click the "Change Download Site" 
button. 
2. In the drop-down menu, change the download site to Test and then 
click the Ok button. 
3. In the Manage Plugin main window, click the "Change Download Site" 
button again. 
4. In the Plugin Download Sites window, click the "Add Site" button. 
5. Click the "Add" button. 
6. Type in a name and a URL (any) and click OK. 
7. Click OK to exit the Bookmark Manager. Click OK in the Plugin 
Download Sites window to get back to the Plugin Manager main window. 
Click the Close button to exit the Plugin Manager and close Cytoscape.  
 
Expected Results 
 
1. A Plugin Download Sites window will appear with a drop-down menu 
for selecting download site. 
2. A progress bar should appear. When the download site has been 
switched, you should see a different folder structure under Available for 
Install. 
3. When selecting the Add Site button in the Plugin Download Sites 
window, a Bookmark manager window will appear. 
4. When clicking Add in the Bookmark manager, an Add new bookmark 
window will appear. 
5. After adding a new site, the new download site will appear in the list of 
Bookmarks.  
 
Plugins -> Update Plugins 
 
Procedure 
 
1. Start Cytoscape 
2. Click Plugins -> Update Plugins  
 
Expected Results 
 
1. A progress window will appear informing you of the status of updates. 
If no updates are available for installed plugins, a message will appear 
telling you that no updates where available.  
 
Plugins -> Merge networks 
 
Procedure 



 
1. Start Cytoscape 
2. Load two or more networks. 
3. Click Plugins -> Merge networks. 
4. To select networks, click on the network and then click the right arrow. 
Select two or more networks from the list. 
5. Select an operation in the Operation drop-down menu. 
6. Click OK to merge the networks.  
 
Expected Results 
 
1. A Merge Networks dialog should appear with the loaded networks 
listed under Available Networks. 
2. A new network view will open with the results of the merge.  
 

Help Menu 
 
Control Panel - Network 
 
Control Panel - VizMapper 
 
Test 1: Global Commands 
 
Procedure 
 
1. Switch Visual Style from the combo box 
2. All of the following commands are under Options icon (click 
Options...): 

• Select Create new Visual Style... and type new Visual Style 
name 

• Select Delete Visual Style 
• Select Rename Visual Style and type new name 
• Select Copy existing Visual Style and type new name. Change 

background clolor from Default Editor and switch back to the 
original style 

• Select Create legend from current Visual Style. Select eps as 
export type and click Export  

 
Expected Results 
 
1. The selected Visual Style should be applied on the current network 
view 
2. Option commands should behave like the following: 

• New visual style should be created. The new style has only 
name mapping (ID) 



• Currently selected visual style will be removed from the 
combo box and default style will be applied. If the selected 
style is default error message will be appear on the window. 

• The new name appear on the combo box 
• Copied visual tyle should appear in the combo box. Once one 

of the properties has been changed, the two style should 
look different 

• The generated vector image file should be readable with 
Acrobat  

 
Test 2: Default View Editor 
 
Test 3: Individual Mapping Editors 
 
Test 4: Right-Click Menu 
 
Procedure 
 
1. Select Lock Node Width/Height and then select again to switch back to 
the original value.  
 
Expected Results 
 
1. If unlocked, Node Width and Node Height will be displayed on the list. 
Otherwise, only Node Size is shown. Also, Default view should be updated 
accordingly.  
 
Passthrough Mapper 
 
Discrete Mapper 
 
Continuous Mapper 
 
Control Panel - Editor 
 
There are multiple tests for the Cytoscape Editor: 
 
Control Panel - Editor -> add a simple interaction 
 
Procedure 
 
1. Click File -> New -> Network -> Empty Network to bring up a new 
network and the editor palette. 
2. Click on a node in the editor Palette and drag/drop it onto the network 
view to form node0. 



3. Repeat step 2 to add a second node to the network view (node1). 
4. Click on an edge in the editor palette, drag/drop it onto onto node0. 
5. Move the mouse to drag the rubberband line from node0 to node1. 
6. Release mouse when over node1.  
 
Expected Results 
 
1. You should see a network of two nodes, node0 and node1, connected 
by a single edge.  
 
Control Panel - Editor -> keyboard accelerators 
 
Procedure 
 
1. Click File -> New -> Network -> Empty Network to bring up a new 
network and the editor palette. 
2. Control-click on an empty space on the canvas to add a node to the 
network view. 
3. Repeat step 2 to add a second node to the network view 
4. Control click on one of the two added nodes to begin an edge. This will 
be source node. 
5. Move the mouse to drag the rubberband line from source node to the 
other node (target node). 
6. Release mouse when over target node.  
 
Expected Results 
 
1. You should see a network of two nodes, source node and target node, 
connected by a single edge.  
 
Control Panel - Editor -> connect selected nodes 
 
Procedure 
 
1. Click File -> New -> Network -> Empty Network to bring up a new 
network and the editor palette. 
2. Control-click on an empty space on the canvas to add a node to the 
network view. 
3. Repeat step 2 several times to add other nodes to the network view 
4. Select all the nodes by clicking on an empty space on the canvas, then 
dragging a rubberband rectangle around all the nodes (or use Control-A 
keyboard accelerator) 
5. Select Edit -> Connect Selected Nodes menu item.  
 
Expected Results 



 
1. You should see a clique, i.e. there is an edge connecting every pair of 
nodes  
 
Control Panel - Editor -> change visual style 
 
Procedure 
 
1. Select Vizmapper(tm) tab in Control Panel. 
2. Select a different visual style by choosing it from combo box under 
Current Visual Style. 
3. Select Editor tab in Contol Panel  
 
Expected Results 
 
1. You should see a different set of node shapes and edge lines on the 
Editor palette.  
 
Control Panel - Editor -> delete nodes and edges 
 
Procedure 
 
1. Click File -> New -> Network -> Empty Network to bring up a new 
network and the editor palette. 
2. Control-click on an empty space on the canvas to add a node to the 
network view. 
3. Repeat step 2 several times to add other nodes to the network view 
4. Select all the nodes by clicking on an empty space on the canvas, then 
dragging a rubberband rectangle around all the nodes (or use Control-A 
keyboard accelerator) 
5. Select Edit -> Connect Selected Nodes menu item. 
6. Select a subset of nodes and edges by dragging a rubberband 
rectangle around several nodes and edges 
7. Select Edit -> Delete Selected Nodes and Edges menu item.  
 
Expected Results 
 
1. You should see the selected set of nodes and edges disappear. Also, 
any edges that connect deleted nodes to non-deleted nodes will also 
disappear.  
 

Control Panel - Filters 
 
Data Panel - Node, Edge, and Attribute Browser 
 



Workflow Testing 
 
The goal of this section is to verify that the various workflows described 
for Cytoscape do actually work. In addition to the workflows described, 
we will also verify that each tutorial also works. The output of these tests 
will be different than simply a checklist. The goal is to capture the steps 
in the workflow in a screencapture movie. The movie should capture the 
screen as a user follows each step in the workflow or tutorial. Audio 
commentary is preferred since this allows to both see and hear the steps 
being followed. 
 
Workflow 1: Annotating a Network with Web Services 
 
Requirments 
 
This workflow needs the following plugins: 
 
 * Biomart Client 
 * Biomart Client UI  
 
Test Procedure 
 
(Under construction) 
 
1. Import galFiltered.sif. This is a yeast network with Ensembl Gene ID as 
node identifier. 
2. File-->Import-->Attributes from Biomart. Task Monitor appears and 
the plugin builds GUI based on the entries returned from Biomart. 
3. Select ENSEMBL 48 GENES (SANGER) - Saccharomyces cerevisiae genes 
(SGD 1.01) for Data Source 
4. Make sure Attribute is set to ID 
5. Set Data Type' to Ensembl Gene ID(s) 
6. From the attribute list, select the following: 
 * EntrezGene ID 
 * SGD 
 * Unified UniProt Accession  
7. Press Import' 
8. Go to Attribute Browser's menu bar and click Select Attributes' icon and 
select newly imported attributes. Make sure most of the nodes are 
annotaed. 
9. Go back to the Biomart Web Service window. Switch Data Source' to 
ENSEMBL 48 HOMOLOGY (SANGER) - Homo sapiens 
(NCBI36)|Saccharomyces cerevisiae genes (SGD 1.01)|Orthologues. 
10. Select S. cer Ensembl Gene ID(s) for Data Type' 
11. From the annotation list, select the following: 



 * H. sap ensembl gene ID 
 * H. sap display label 
 * H. sap homology peptide % ID  
 
12. Press Import' 
13. Check imported attributes in Attribute Browser. 


