← Revision 5 as of 2005-09-30 21:34:05
Size: 1225
Comment:
|
← Revision 6 as of 2005-09-30 22:24:56 →
Size: 1454
Comment:
|
Deletions are marked like this. | Additions are marked like this. |
Line 23: | Line 23: |
GaryBader - 9/30/05 - If we add deleteAttribute to permanently remove an attribute from Cytoscape, which I think we would, I think the deleteAttribute method that is in Ethan's current proposal should be called clearAttribute |
Describe RFC 1/RFC1 Comment API here.
IlianaAvila -9/30/05- I put in this new comment section, since I had additional comments that did not fit in any existent category.
IlianaAvila -9/30/05- I think we also need:
/** * Deletes the given attribute completely for all objects */ boolean deleteAttribute (String attributeName);
The implementation for this method can be more efficient than calling deleteAttribute (String id, String attributeName) for all ids. But I don't know how attributes are stored, so maybe it would be the same.
NeriusLandys -9/30/05- See CyDataDefinition.undefineAttribute(String).
IlianaAvila -9/30/05- I think the method should be in CyAttributes, and called deleteAttribute(String). The name undefineAttribute seems strange.
IlianaAvila -9/30/05- I am not sure that I like to have the additional CyData and CyDataDefinition interfaces. I like the idea of having one single interface to handle attributes for Cytoscape. What additional methods do these interfaces have? Are they really going to be used? Could we put the needed ones in CyAttributes?
NeriusLandys -9/30/05- I think Ethan's API is fairly intuitive and would definitely be a cinch to implement.
GaryBader - 9/30/05 - If we add deleteAttribute to permanently remove an attribute from Cytoscape, which I think we would, I think the deleteAttribute method that is in Ethan's current proposal should be called clearAttribute