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Cytoscape:
Biological Network Analysis Training
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Cytoscape:
Biological Network Analysis Training

1. Introduction to Cytoscape Software
This section will introduce the Cytoscape user interface and includes central
organising metaphors of Cytoscape: a network consists of

genes/proteins/metabolites as nodes and interactions represented as links i.e. edges
between nodes

First of all we will look at the basic UI of Cytoscape. Then we will load up a network

to show all menu features of Cytoscape and some of the core functionality such as
layout algorithms and also its plug-ins.

1.1 Cytoscape Layout and User Interface
Launch Cytoscape: You should see a window that looks like this
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e At the top of the Cytoscape Desktop window is the toolbar, which contains the
command buttons. The name of each command button is shown when the
mouse pointer hovers over it.

e In the upper right is the Main Network View window, where network data will
be displayed. This region is initially blank.

e At left is the Control Panel (Network Management) Panel. This lists the
available networks by name and provides information on the number of nodes
and edges.

Immediately below the Control Panel is the Network Overview Pane
At lower right is the Data Panel which can be used to display node, edge, and
network attribute data
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The Network Management and Data browser panels are dockable tabbed panels
known as CytoPanels. You can undock any of these panels by clicking on the Float
Window control in the upper-right corner of the CytoPanel.

1.2

Loading Networks

We will now load a network to show all features of Cytoscape UI

Go to File-> Import -> Network (multiple file types)

You should see the Import Network File Dialog

For Data Source Type select Local and then click Select

Open the sampleData folder and select galFiltered.sif and then click on
open and then Import

You should see the following:
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We will now use some of the basic Cytoscape functionality to re-organise and move
around the network.

Go to the Layout -> yFiles -> Organic to change the layout of the network
Use the Network Overview Pane to move and navigate across the network
The Network Management Pane of the Control displays the number of
nodes and edges in your network

You can select nodes by clicking on them with the mouse, or by creating a
selection area by dragging with the left mouse button

Note that the Node Attribute Browser on the Data Panel lists the
information stored on the nodes

You can also select edges by clicking on a few edges; again, note that
information about the edges can be viewed on the Edge Attribute Browser
of the Data Panel
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1.3 Cytoscape menus

We will briefly run through all the menus available in Cytoscape.

File
The File menu contains basic file functionality:

e File — Open for opening a Cytoscape session file

e File - New for creating a new network

e File — Save for saving a session file

¢ File - Import for importing data such as networks and attributes

¢ File —» Export for exporting data and images.

e File — Print allows printing

¢ File — Quit closes all windows of Cytoscape and exits the program
Edit

The Edit menu contains:

¢ Undo and Redo functions which undo and redo edits made in the Attribute
Browser, the Network Editor and the Layout.

e Options for creating and destroying views (graphical representations of a
network) and networks
Options for deleting selected nodes and edges from the current network.
All deleted nodes and edges can be restored to the network via Edit — Undo.

e Edit — Preferences — Properties to edit preferences for properties and
plugins

View
The View menu allows you to display or hide:

e The network management panel (Control Panel)
e The attribute browser (Data Panel)
¢ Results Panel
e VizMapper
Select

The Select menu contains:
e Options for selecting nodes and edges
e The Select — Use Filters option allows filters to be created for automatic
selection of portions of a network whose node or edge attributes meet a
filtering criterion (see below for the filters section).

Layout
The Layout menu has an array of features for visually organising the network:
¢ Rotate, Scale, Align and Distribute are tools for manipulating the network
visualisation.
e The bottom section of the menu lists a variety of layout algorithms which
automatically lay a network out.
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Plugins
The Plugins menu contains options for managing your plugins (install/update/delete)
and may have options added by plugins that have already been installed, such as the
Agilent Literature Search or Merge Networks.
e Depending on which plugins are loaded, the plugins that you see may be
different than what appear here.

Help
e The Help menu allows you to launch the help viewer and browse the table of
contents for this manual.
e The “About...” option displays information about the running version of

Cytoscape.

1.4 Manipulating Networks

Zooming
Cytoscape provides two mechanisms for zooming:
i) Using the mouse - right click and move the mouse forward and backwards
i) Using the zoom buttons on the toolbar to zoom in and out of the
interaction network shown in the current network display. Zoom icons are
detailed below:

From Left to Right:
e Zoom Out; Zoom In; Zoom Selected Region; Zoom Out to Display all of
Current Network

Panning the network

You can pan the network image by holding down the middle mouse button and
moving the mouse in the main network window. You can also pan the image by
holding down the left mouse button on the Network Overview panel in the lower left
hand of the Cytoscape desktop

Manually rearrange a network
Select the nodes of interest and move them around.

Automatically rearrange a network
There are a variety of layout algorithms which can be found in the Layout Menu
e Select Layout -> Cytoscape Layouts -> Degree Sorted Circle Layout ->
All Nodes
o Your network has now been re-arranged and the algorithm partitions
the network based on the connectivity of the nodes (i.e. degree)
o The circles themselves are arranged in a radial tree layout fashion.
o This algorithm also calculates the degree for each node which cab be
viewed in the Node Attribute Browser as follows:
= On the Data Panel, select the Node Attribute Browser tab,
click on Select Attributes, select Degree then click on any
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node, the degree of the node as calculated by the Degree
Sorted Circle Layout will be displayed
Try other layout algorithms from the Layout menu.
Rotating and Scaling your network
Finally you can rotate and scale your network within Cytoscape.
e Go to the Layout Menu -> Rotate, the Tool Panel will appear at the bottom
left of the screen
e Select a few nodes and click on Rotate Selected Nodes Only in the Tool
Panel, move the slider to 90 degrees to rotate the nodes.
e Note you can also rotate the whole network.
e You can also change the scale of the network (or selected nodes) by clicking
on the Scale tab in the Tool Panel
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2. Constructing and Loading Biological Networks into
Cytoscape

In this section we will show the ways in which you can load in your own networks
and associated data in to Cytoscape

There are three ways of creating networks in Cytoscape and we will deal with each of
these in turn:

e Importing network files.

e Importing text or Excel files.

e Creating an empty network and manually adding nodes and edges.

First of all it's useful to understand the files formats that are used for networks and
the associated data.

2.1 Importing network files into Cytoscape

Cytoscape can read network/pathway files written in the following formats:
¢ Simple interaction file (SIF or .sif format)

Graph Markup Language (GML or .gml format)

XGMML (extensible graph markup and modelling language).

SBML

BioPAX

PSI-MI Level 1 and 2.5

The simple interaction format (sif) is convenient for building a graph from a list of
interactions. The main disadvantage is that this format does not include any layout
information, forcing Cytoscape to re-compute a new layout of the network each time
it is loaded.

An example of a sif file format is:

nodeA <relationship type> nodeB
nodeC <relationship type> nodeA

We will open galFiltered.sif in Excel to illustrate this
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2.2

Importing text or Excel files

Cytoscape can also read file structures are the Delimited Text or Excel

Go to File-> Import->Network from Table (Text/MS Excel)

You should see the Import Network from Table Dialog Box

In Data Sources, click on Select File

Select human_interactome_may07_small.tab.gz from the sampleData
folder and then click on Open. You should now see the screen below.
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In the Advanced section, select Show Text File Import Options

In the Delimiter section, deselect Space

In the Attribute Names section, select Transfer first line attribute names
In the Preview section click on the columns you want to import: Aliases A,
Aliases B, Interaction Detection Methods, Interactor Types

The next step is to define the interaction parameters by specifying which columns of
data contain the Source Interaction (i.e. source node), Target Interaction (i.e. target

node) and Interaction Type in the Interaction Definition pane. If you set the Interaction
Type as "Default Interaction”, all interactions will be given the value "pp”; this value can be modified in
Advanced Options.

For the Source Node
o For the Source Interaction dropdown list, select Column 1
For the Target Node
o For the Target Interaction dropdown list Select Column 2
For the Interaction
o For the Interaction Type dropdown list Select Column 4
Note Column 3 (“Interaction detection methods”) is highlighted in blue and
will be imported as edge attributes.
Click on Import
In the Network Manager section of the Control Panel a network of 10,176
nodes and 61240 edges is highlighted in red.
Note that due to the size of the network, it will not be displayed in the Main

window.
To create the view, right click on the Network name and select Create View
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2.3 Creating an empty network and manually adding nodes
and edges

It is also possible to create new, empty networks that nodes and edges can be
manually added to.

e To create an empty network, go to File — New — Network — Empty
Network
Select the Editor tab from the Control Panel
To add a node to a network, drag and drop a node shape from the palette
onto the canvas. Add another node

e To connect two nodes with an edge, drag and drop an arrow shape onto a
node on the canvas. This node becomes the source node of the edge.

e Move the cursor and a rubber-banded line will follow the cursor. As the cursor
passes over another node, that node is highlighted and the rubber-banded
line will snap to a connection point on that second node.

Click the mouse while over this node and the connection will be established.
You can delete nodes and edges using the following method

e Select a node and hit the Delete button on your keyboard or by Edit->Delete

selected nodes and edges

You can also create networks using the following scheme
e Double click on any empty space in the Main Network window and you should see
the Input dialog box. Type in the following

A binds B and then click on OK
Repeat above and type in

C binds D and then

D binds A and then

A binds A

O O O O O

You should have a new network of 5 nodes and 4 edges (this information about the

number of nodes can be found by clicking the Network tab on the Control Panel)

e You can edit the name of the network by right clicking on the Network name in
the Control Panel and selecting Edit Network Title
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2.4 Fetching data from external sources using other
databases

Agilent Literature Search

e To create an empty network, go to File - New — Network — Empty Network

e Under the Plugins menu, select Agilent Literature Search

¢ In the Terms window, enter p53. The term “p53” should appear in the Query
Editor, and the forward arrow just below should turn blue to indicate it is
available.

e Click on the Play button to begin searching.

e Under Query Matches, there should appear a numbered list of articles labelled
Results.

e A slider at the right side of the window allows you to scroll through the list of
selected articles

e Each article should be listed along with a URL, and a hyperlink for jumping
directly to that URL

e A network should appear in Cytoscape, showing interactions inferred from
sentences in the selected articles.

e Right click on the edge between ctcf and ctcfl

e Select "Show Sentences from Agilent Literature Search”.
Click on a URL to access the PubMed article

Linking to external data using LinkOut

LinkOut provides a mechanism to link nodes and edges to external web resources
within Cytoscape.

e Select a node of interest,

e Right click on a node and pop up menu with a list of web links will be displayed
e Select yeast and then SGD

The external links are can be specified and edited by modifying the link out
properties found under Edit — Preferences — Properties

e Select the human_interactome_may07_small.tab network

Go to Edit — Preferences — Properties

Click on Add in the Properties section

Type in nodelinkouturl.human.BioGrid as a Property Name

Type in the following for Property Value,
http://www.thebiogrid.org/search.php?keywords=%ID%&searchbutton=GO&org
anismid=9606

e Click on OK

e Type in SERPINAL1 in the search box and click ok

¢ Right click in the selected node, select human and then BioGrid

2.5 Saving Sessions
You can save your Cytoscape sessions and export visualisations.

To save a session, go to File->Save
e Networks, Attributes, Visual Styles and Layouts will be saved as a CYS file
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¢ You can export networks and attributes individually File->Export->Network
as sif File... or File->Export->Node Attributes

You can also export images from Cytoscape:
e File->Export->Network View as Graphics

Page 12 of 31 Tutorial: Cytoscape Retreat 2007



3 Working with Attributes

Once you have created a network it is important to overlay relevant data and
information. Cytoscape allows you to add information to the nodes, edges and the
network as a whole.

3.1 Importing Node Attributes

There are various file formats for node and edge attributes and details can be found
in the Help section in Cytoscape.

As of Cytoscape 2.4, importing delimited text and MS Excel attribute data tables is
now supported.

The attribute file should contain a primary key column and at least one attribute
column.

We will look at the node attributes for the galFiltered network.

<Open galFiltered.nodeAttrTable.xls as an example>

To Import Node Attributes

e Select File — Import — Attribute from Table (Text/MS Excel)
e Select one Node from the Attributes radio buttons. Cytoscape can import node,
edge, and network attributes

"€ Import Annotation File &3]

w2 @ Import Attribute from Table

Data Sources
Attribites () Node () Edge () Metwork

Advance -d
[]'Shaw Mapping Options [7] Show Text File Import Options
Preview
Left Click: Enable/Disable Column, Right Click: Edit Column Legend: [IECTI DS

Data File Preview Window ey Attributes
? I
Source
Target
2 YALOOSW
YALO30W.
YALO38W
YALO40C
YARQOTC ~

File Size: Unknawn Tmport

e To load a local file, click on the Select File button and open the sampleData
folder, select galFiltered.nodeAttrTable.xls and click on Open

e (Optional) If the table is not properly delimited in the preview panel, change the
delimiter in the Text File Import Options panel. The default delimiter is the tab.
This step is not necessary for Excel Workbooks.

e By default, the first column is designated as the primary key. Change the key

column if necessary.

In the Advanced pane, select "Show Text File Import Options”

In the Attribute Names pane, select “"Transfer first line attribute names”

In the Preview pane click on the columns you want to import (Click them all)

Double click on the second column to change the from “alias” to

“AlternativeName”

e Click on Import
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3.2 Viewing Attributes

The node attributes can be viewed in the Node Attribute Browser of the Data Panel.
To swap between nodes, edges or network browsers click on the appropriate tabs on
the Data Panel

To view the node attributes you have just loaded in, click on the Select Attributes

button in the Node Attribute Browser

=

Select the following Node Attributes by clicking in check boxes
e DB_Object_Name

GO Biological Process
GO Molecular Function
GO Cellular Component
Taxon

Select any nodes on the network and the attributes will be displayed in the Node
Attribute Browser of the Data Panel:

0l
2l
HO = O=K
D DB_Object_Name | O BIOLOGICAL_PROCESS | 60 cELLULAR_COMPONENT GO MOLECULAR_FLINCTION [ Taxon
YJL180C ribosomal prot... | telomere mainienance | eytosolic small ribosomal su... | structural constituent of ribosome | Saccharomyces (
YBRO18C galaciose-1-ph... | galaciose catabolic process | cytoplasm | UTP:galaclose-1-phosphate uridyiyliransfera.. Saccharomyces (
YNL307C 43.1 kDa serin... | double-strand break repair via nonhomaologo... | soluble fraction | glvcogen synthase kinase 3 activity, protein th... | Saccharomyces o
YNLO38W response to oxidative stress | eytoplasm, nucleus | carbonate dehydratase activity Saccharomyces ¢
YMR117C spindle pole co chramosome segregation, microtubule nucle . | Ndc80 complex, condensed _ | structural constituent of cytoskeleton Saccharomyces o
YOR202W imidazoleglycer... | histidine biosynthetic process intracellular | imidazaleglyceral dehydratase act Saccharomyces =
YHR179W NAPDH dehydr... | biological_process cytoplasm, mitochondrion, n... | NADPH dehydrogenase activity Saccharomyces o
YDL194W glucose sensor | response to glucose stimulus, signal transdu... | plasma membrane | glucose binding, glucose ir activity, r... | Saccharomyces ¢
YPL248C zinc finger tran... | galactose metabolic process, positive regulat... | nucleus | transcription factor activity, transcriptional activ... | Saccharomyces
YDR16TW TFID subunit, G1-specific transcription in mitotic cell cycle, ¢ | SAGA complex, SLIK (SAGA-li . | general RNA polymerase Il transcription facto Saccharomyces o
YHRO53C copper binding response to copper ion | cytosol | copper ion binding Saccharomyces o
YBR170C ER-associated protein catabolic process | nic reticulum, nucl... | molecular_function Saccharomyces o
YGL134W regulation of glycogen hiosynthetic process, r... | eyclin-dependent protein kina... | eyclin-dependent protein kinase regulator acti.. | Saccharomyces o
YKL204W telomere maintenance | MRMNA cap complex eukaryotic initiation factor 4E hinding Saccharomyces (
YMLO32C DNA recombinase assembly, double-strand ... | nuclear chromosome, nucleus | DNA strand annealing activity, recombinase a... | Saccharomyces ¢
 YER133W protein phosph. 358 primary transcript processing, cell buddi bud neck, mRNA cleavage a protein phosphatase type 1 activity Saccharomyces o
YIDR299W ER to Goloi vesicle-mediated transport | nuclenlus | molecular_function | Slacl:harnmyl:ea [i v|
4 »

" Node Attribute Browser | Edge Attribute Browser | Network Attribute Browser |

e The right-click menu on the Attribute Browser has several functions, such as
exporting attribute information to spreadsheet applications.
e For example, use the right-click menu to Select All and then Copy the data,
and then paste it into a spreadsheet application
e You can also link out to external resources by right clicking a cell in the table
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3.3 Deleting Attributes

To delete attributes from the browser (and CYTOSCAPE!) click on the Delete
Attribute Button

>

Select the attributes you want to delete and then click on Delete

3.4 Editing Attributes

You can also edit attributes by double clicking on the appropriate cell in the Node
Attribute Browser

3.5 Importing Ontologies

Note you can also import Ontology and Annotation by doing the following:
File-> Import-> Ontology and Annotation
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4 Working with Data

It is not only useful to add information to networks as we have just done. In addition
to normal node and edge attribute data, Cytoscape also supports importing gene
expression data (and any other molecular state data).

Network-based analysis of High Throughput data is a very useful tool in systems
biology and many other disciplines and this section will cover the integration of HTP
data with biological networks in order to perform powerful visualisation and analyse
in a biological context.

PLEASE NOTE: DNA microarray data will be used as an example in this section of
the tutorial however other types of data can be used

Gene expression data are imported using a different file format than normal
attributes; however, the resulting attributes are not treated differently by Cytoscape.
Gene expression data (like attribute data) can be loaded at any time, but are
(generally) only relevant once a network has been loaded.

4.1 File format

The file format for importing molecular state data (or any other data) consists of a
header and a number of space- or tab-delimited fields, one line per node, with the
following format:

Identifier [CommonName] valuel value2 ... valueN [pvall pval2 ... pvalN]
Let’s take a look at a Gene Expression file to get an idea of the format

Brackets [ ] indicate fields that are optional.
The first field is a primary key that identifies which Cytoscape node the data
refers to.

o In the simplest case, this is the gene name - exactly as it appears on
the network generated by Cytoscape (NOTE it is case sensitive!).

o Alternatively, this can be some node attribute that identifies the node
uniquely, such as a probeset identifier for commercial microarrays.

e The next field is an optional common name. It is not used by Cytoscape, and
is provided strictly for the user's convenience.

e The next set of columns represent expression values, one per experiment.
These can be either absolute expression values or fold-change ratios. Each
experiment is identified by its experiment name, given in the first line.

e Optionally, significance measures such as P values may be provided.

o If you are using significance measures, then your expression file
should contain them in a second set of columns after the expression
values. The column names for the expression significance measures
need to match those of the expression values exactly.

Expression data files commonly have the file extensions ".mrna" or ".pvals", and
these file extensions are recognised by Cytoscape when browsing for data files.
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4.2

Loading Expression Data

We will now load the expression data for the galFiltered network:

Go to File —» Import — Attribute/Expression Matrix....

The Import an Attribute/Expression Matrix will be displayed

In the field labelled "Please select an attribute or expression matrix file...",

click on the Select button

Select galExpData.pvals the sampleData folder and click on Open

o The identifiers used in this file are the same ones used in the network

file sampleData/galFiltered.sif, so you do not need to touch the field
labelled "Assign values to nodes using...”

Click on Import and details of the expression data will be displayed

That’s it! You've now integrated your experimental data with your network.

In the next section we will learn how to us the visualisation and filtering tools in
Cytoscape to start to use this data for network-based analysis
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5 Customising Visualisation of Networks

Customising the way you visualise and manipulate networks is a key function of
Cytoscape. This is achieved through the use of the VizMapper tool and in this section
we will co through this functionality in some detail.

Following on from the previous sections, we will use the networks and data that have
already been loaded in but remember, this will work with whatever data you are
interested in.

5.1 The basics of VizMapper in Cytoscape

To launch the VizMapper, either select the VizMapper tab on the Control Panel or
click on the VizMapper icon at the top of the tool bar

B Control Panel o =] 9

Ts Network | VizMapper™ | Regions | Edtor | Fiters |

Current Visual Style
[efute | @ ,
Defaults
org =

Visual Mapping Browser

8l
Edge Label Al
Edge Label Color
Edge Label Opacity
Edge Line Style
Edge Line Width
Edge Opacity
Edge Source Arrow Color
Edge Source Arrow Opacity
Edge Source Arraw Shape
Edge Targst Arrows Color
Edge Target Arrows Opacity
Edge Target Arrow Shape
Edge Tooltip =

There are 3 components in the VizMapper UI:

Current Visual style
This panel allows you to create/delete/view/switch between different visual
styles using the Current Visual Style options.

Defaults Appearance Style

Clicking on the section labelled "Defaults" on the Main Panel will bring up an
editor, which allows users to visually edit the default appearance of nodes and edges
for the selected visual style.

Visual Mapping Browser

Visual Mapping Browser at the bottom displays the mapping details for a given visual
style and is used to edit these details as well.
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5.2 Different types of Visual Mapping in Cytoscape

Before we start creating our own visual styles there are a few concepts that need to
be understood.

The Cytoscape VizMapper uses three core concepts:

A visual attribute is any visual setting that can be applied to your network.
For example, you can change all nodes from circles to squares by changing

the node shape visual attribute.

A network attribute is any data attribute associated with a node or an edge.
For example, each edge in a network may be associated with a label, such as
“pd” (protein-DNA interactions), or “pp” (protein-protein interactions).

A visual mapper maps network attributes to visual attributes. For example,
a visual mapper can map all protein-DNA interactions to the colour blue, and

all protein-protein interactions to the colour red

What can we visualise?
Cytoscape allows a wide variety of visual attributes to be controlled details of which
can be found in the Cytoscape User Manual. Examples include:

Nodes

Edges

Node Colour

Node Opacity

Node Border Colour
Node Border Opacity
Node Shape

Edge Source and Target Arrow Colour
Edge Source and Target Arrow Opacity

Edge Label: the text label for each edge.

Edge Label Colour
Edge Label Opacity
Edge Font: edge label font and size.

Global Visual Properties

Background Colour
Selected Node Colour
Selected Edge Colour
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The types of Visual Mappers
For each visual attribute, you can specify a default value or define a dynamic visual
mapping. Cytoscape currently supports three different types of visual mappers:

1. Pass-through Mapper
The values of network attributes are passed directly through to visual
attributes. A pass-through mapper is only used to specify node/edge
labels. For example, a pass-through mapper can label all nodes with their
common gene names.

2. Discrete Mapper
Discrete network attributes are mapped to discrete visual attributes. For
example, a discrete mapper can map all protein-protein
interactions to the colour blue.

3. Continuous Mapper
Continuous graph (usually numerical) attributes are mapped to visual
attributes.

5.3 VizMapper Examples

The best way to learn about the VizMapper is to try to use it on some real examples.
In this tutorial we will look at a few examples

e Example 1: Creating a Basic Visual Style and Setting Default Values

e Example 2: Creating a New Visual Style with a Discrete Mapper

e Example 3: Visualizing Expression Data on a Network

e Example 4: How to Use Utilities for Discrete Mappers

5.3.1 Example 1 - Creating a basic visual style and setting
default values

We will continue to use galFiltered.sif
e Ensure that galFiltered is selected in the Control Panel
¢ Open the VizMapper
¢ In the Current Visual Style section, create a new visual style by clicking the

Options button fc) and selecting “Create new Visual Style”

Enter a name for your new visual style when prompted, click on OK

You will see an empty visual style in the VizMapper Main Panel, as shown
below.

Visual Ktapping Browser
=) Lrsed Properties A
Node Border Color

tioce Shape
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Since no mapping is set up yet, all visual attributes are listed in the Unused
Properties category of the Visual Mapping Browser.

To edit default values, open the Default Appearance Editor by clicking on the
Defaults graphics window (shown below) in the VizMapper Main Panel.

&' Default Appearance for Tutorial 1 3

NODE_FILL_COLOR
NODE_BORDER_COLOR

CJ
l:l NODE_SHAPE
35.0

NODE_SIZE

NODE_LABEL

Font woce_rour_face

49 n NODE_FOMT_SI7F -
[¥] Lock Moda WidthiHeight dopty | | Nede Edge | Global

¢ The next step is to change the default node shape.

To set the default node shape to triangles, click Node Shape in the Default

Visual Properties list. A list of available node shapes will be shown.

Click on the Triangle icon and then click the Apply button.

The Default Appearance Editor will be automatically updated.

The next step is to change the node colour

Click on Node_Fill_Color in the Default Visual Properties list, the colour

selection panel will appear. Select red, then OK and then Apply

The end result is that all nodes are red triangles

e Other default values can be edited by clicking on visual attribute names on
the list.

¢ To change default edge properties, select the Edge tab on the Default
Visual Properties section

e To change default global properties, select the Global tab on the Default
Visual Properties section
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5.3.2

Example 2: Creating a New Visual Style with a
Discrete Mapper

The following tutorial demonstrates how to create a new visual style using a discrete
mapper. Recall that discrete network attributes are mapped to discrete visual
attributes. The goal is to draw protein-DNA interactions as dashed blue lines, and
protein-protein interactions as solid red lines.

Using galFiltered.sif

Open the VizMapper
In the Current Visual Style section, create a new visual style by clicking the

Options button b

Select Create new visual style

Then enter a name for your new visual style when prompted, click on OK
Next step is to choose a visual attribute

Since we want to change the edge colour, double click the Edge Colour entry
listed in Visual Mapping Browser. Edge Colour will now appear at the top of
the list, under the Edge Visual Mapping category

The next step is to choose a network attribute

Click on the cell to the right of the Edge Colour entry and select interaction
from the dropdown list that appears

The next step is to specify the type of mapping

Click on the cell next to the Mapping Type entry and select Discrete
Mapper from the dropdown list

All available attribute values for interaction will be displayed

The next step is to set the mapping relationship

Click the empty cell next to pd (protein-DNA interactions).

On the right side of the cell, ... and X buttons will appear

Click on the ... button. A popup window will appear; select blue and the
change will immediately appear on the network window.

Repeat above steps for pp (protein-protein interactions) but select red as the
edge colour

Can you also specify that your protein-protein interactions should be solid and the
protein DNA interactions will be dashed?
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5.3.3 Example 3: Visualizing Expression Data on a
Network (Using continuous mapper)

The following tutorial demonstrates how to create a new visual style using a
continuous mapper.

The goal is to superimpose gene expression data onto a network and display gene
expression values along a colour gradient.

Using galFiltered.sif

¢ (Load in galFiltered.sif and the associated expression data set:
galFiltered.pvals)

e (Ensure galFiltered is selected in the Control Panel)
¢ Open the VizMapper

In the Current Visual Style section, create a new visual style by clicking the

Options button [ie

Select Create new visual style

Then enter a name for your new visual style when prompted, click on OK

Next step is to choose a visual attribute

Since we want to change the node colour, double click the Node Colour entry

listed in Visual Mapping Browser. Node Colour will now appear at the top of

the list, under the Node Visual Mapping category

e The next step is to choose a network attribute

e Click on the cell to the right of the Node Colour entry and select gallRexp
from the dropdown list that appears

e The next step is to specify the type of mapping

¢ Click on the cell next to the Mapping Type entry and select Continuous
Mapper from the dropdown list

e The next step is to define the points where the colours will change

¢ Click on Graphical View in the Node Visual Mapping category. The
Gradient Editor for Node Colour will appear

e C(Click the Add button twice to create two data points, which will show up as
overlapping triangles at the right of the scale.

e C(Click and drag one point to -1, or type the value in the Range Setting box.
Set the second point to 2.

e The next step is to define the colours between points.

Double-click on the leftmost triangle (facing left) and a colour palette will

appear. Choose a shade of green and click OK.

Make the triangle at -1 a shade of green.

Double-click on the triangle set at 2, and set its colour to red.

Set the rightmost triangle to Red.

The end result is shown below

2 Gradient Editor for, Node Color,

Continuous Mapping for Node Color
< v Al 2

\ 2.0000/
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Range Setting
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The colour gradients will immediately appear in the network window. All nodes with a
gallRGexp value less than -1 will be set to green, and all nodes with a gallRGExp
value greater than 2 will red. Additionally, all values between -1 and 2 will be
painted with a green to red colour gradient.
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5.3.4

Example 4 — How to Use Utilities for Discrete
Mappers

The following tutorial demonstrates new features in Cytoscape 2.5. The new
VizMapper user interface has some utilities to help users editing discrete mappings.
The goal of this section is learning how to set and adjust values for discrete
mappings automatically.

Using galFiltered.sif

e (Load in galFiltered.sif)

e (Ensure galFiltered is selected in the Control Panel)

e Apply the Degree Sorted Circle Layout to the network: From the main menu,
select Layout — Cytoscape Layouts — Degree Sorted Circle Layout. This
layout algorithm sort nodes in a circle by degree of the nodes. Degrees will be
stored as node attribute names Degree after you applied this algorithm. You
can check this in the Node Attribute Browser

¢ Open the VizMapper

¢ In the Current Visual Style section, create a new visual style by clicking the
Options button

The next step is to change the default appearance to:
Node Opacity: 100

Edge Colour: White

Background Colour: Black

O
@)
@)
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The next step is to create a Discrete Node Colour Mapping

e Since we want to change the node colour, double click the Node Colour entry
listed in Visual Mapping Browser. Node Colour will now appear at the top of
the list, under the Node Visual Mapping category

e The next step is to choose a network attribute, select Degree as controlling
attribute.

¢ Click on the cell next to the Mapping Type entry and select Discrete
Mapper from the dropdown list
All available attribute values for Degree will be displayed
Right click on Discrete Mapping and Select Generate discrete values —
Rainbow 1. It generates different colours for different attribute values as
shown below

The next step is to create a Discrete Node Size Mapping

¢ Double click the Node Size entry listed in Visual Mapping Browser

e The next step is to choose a network attribute, select Degree as controlling
attribute.

¢ Click on the cell next to the Mapping Type entry and select Discrete

Mapper from the dropdown list

All available attribute values for Degree will be displayed

Right click on Discrete Mapping Select Generate discrete values — Series.

Type 30 for the first value and click OK. Enter 15 for increment.

Apply Force-Directed layout (Layout->Cytoscape Layouts-> Force-

Directed Layout). Final view of the window looks like the following.
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5.4 Other aspects of visual styles

Continuous-Continuous Editor

Continuous-Continuous Editor is for creating mapping between numerical attributes
and numerical visual properties (size/opacity). To change the value assigned on Y-
drag the red squares or double click on the squares to directly type exact value.

Continuous-Discrete Editor is used to create mapping from numerical attribute values
to discrete visual properties, such as font, shape, or line style. To edit a value for
specific region, double click on the icon on the track.
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Managing Visual Styles

o All Cytoscape Visual Style settings are initially loaded from a default file called
vizmap.props that cannot be altered by users.

o When users make changes to the visual properties, a vizmap.props file is saved
in the session file.

o This means that assuming you save your session; you will not lose your visual
properties. No other vizmap.props files are saved during normal operation

Saving Visual Styles

o Visual styles are automatically saved with the session they were created in.
Before Cytoscape exits, you will be prompted to make sure you save the
session before quitting.

o Itis also possible to save your visual styles in a file separate from the session
file. To do this, navigate to the File — Export — Vizmap Property File menu
option and save the properties as a file. This feature can be used to share
visual styles with other users.

Importing visual Styles
o To import existing visual styles, navigate to the File — Import — Vizmap
Property File menu option and select a vizmap.props file.
o Imported properties will supplement existing properties or override existing
properties if the properties have the same name.
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6 Filtering and Searching Networks

Searching and filtering networks is another powerful feature of Cytoscape. In this
section we will cover how to go about navigating your networks

6.1 Quick Find

Cytoscape includes a Quick Find feature, which enables you to quickly find nodes and
edges.

) Cytoscape Desktop (New Session)

File Edit View Select Layout Flugins Help

R QA Beol -8B ]

Using Quick Find is very simple.
Using galFiltered.sif
¢ (Load in galFiltered.sif)
e (Ensure galFiltered is selected in the Control Panel)
e Type YPL248C in the search box which will automatically display a list of all
matching nodes
e Hit the returned key and the matching node within the network will be
highlighted and zoomed in
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Configuring Quick Find

Quick Find works by creating an internal index of all nodes within the network. By
default, Cytoscape indexes all nodes by the node identifier. However, you can
configure Quick Find to index nodes or edges, and you can set any attribute as the
index.

e For example, to index the network based on cellular location, click the Quick

Find configuration button

e In the Select Index Type, select Index Nodes

e Select GO_Cellular_Component from the dropdown list of the Search on
Attribute section and then click on Index Network
Type Cytoplasm in the search box
The resulting nodes are highlighted in the network

Dynamic Filtering via Quick Find
If you choose to index on a numerical attribute, the Quick Find search box changes
to a dynamic slider for quick filtering.

e To index the network based on expression, click the Quick Find configuration

button

e In the Select Index Type, select Index Nodes

e Select gal1RGexp from the dropdown list of the Search on Attribute
section and then click on Index Network
A range slider will appear in the search box
Move the slider and the resulting nodes are highlighted in the network
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6.2 Filters

Filters allow you to quickly select multiple nodes or edges of interest by comparing
node and edge attributes loaded onto Cytoscape networks to properties you specify.

For example, you can select all the nodes whose name contains a specific pattern, or
whose numeric attribute value falls within a certain range. Cytoscape provides filters
as a core plugin.

Users can perform complex selection by defining basic filters (selection based on a
single attribute) and compound or Boolean filters (combining basic filters for
selection based on multiple attributes).

There are two types of filters
- Newly designed which allows users to filter on attributes
- Old filters which allows users to filter on attributes and topology

Filtering on Attributes
Using New Filters
e Click on the filter icon on the tool bar
e Alternatively click on the Filters tab on the Control Panel

£ Control Panel E@@
ﬁ,’)]

T Metwork | WizMapper™ | Editor | Filkers

Current Filker

The next step is to define a filter (numerical)
e C(Click on the Filter Option button, select Create New Filter and enter a name
for your filter
e Select gal4RGexp from the Attribute dropdown list of the Filter Definition
section
Click on Add and a slider should appear
Set the slider to -1 to 0 and then click on Apply
The resulting nodes will be highlighted in the network
(You can work with the resulting nodes on a separate network, go to File->
New-> Network-> From selected nodes, all edges)
You can also combine filters
e Select gal4RGexp from the Attribute dropdown list of the Filter Definition
section
e Click on Add and et the slider to 0 to 2
e C(Click on the + sign in the Advanced section and select AND in the Relation
section
Click on apply
(You can work with the resulting nodes on a separate network, go to File->
New-> Network-> From selected nodes, all edges)
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Filtering on Topology
<To filter on topology you will need to use to Old filters (Select->Use Old

Filters)>

6.3 Finding Complexes
Complexes are a special type of module: they are a group of proteins that interact to
form one single piece of cellular machinery, such as the ribosome or the

spliceosome.

This section illustrates a couple of methods for determining complexes.

MCODE
The first is the MCODE method, which follows the principle that highly-connected

regions of the network are often complexes.

Using galFiltered sif
e Launch MCODE (Plugins-> MCODE-> Start MCODE) and the MCODE Plugin
tab will appear in the Control Panel
In the Find Clusters section, select In Whole Network
Click on the Analyze button
The results are shown in the Results Panel
Select a sub-network from the MCODE Cluster Browser
The nodes of the subnetwork will be highlighted in the network
(You can work with the resulting nodes on a separate network, go to File->
New-> Network-> From selected nodes and edges)
e The highest scoring subnetwork shows the peroxisome complex
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